GitHub Pagesでサイト作ってみる(Middlemanで)なぜかエラー編。

GitHub Pages Middleman

Posted on 2015-04-09


初期化しようとするといろいろとMiddlemanでエラーでた。
Gem::ConflictErrorとからしく調べてみたけど今ひとつわからん。
エラーをみてみるとactivemodelというのとactivesupportというがどうもあやしい。

middleman init my_example

2.2.1というのが最新みたいなのでアップデートしても直らない。

ということでアンインストールして入れなおしてみる。
バージョン指定するといけるのかなということでバージョン指定。 まずはactivesupportから。

sudo gem uninstall activesupport
sudo gem install activesupport -v 2.1.10

まずはactivemodelもアンインストールする 。

sudo gem uninstall activemodel
sudo gem install activemodel -v 2.1.10

でまだmiddleman-targetがロードできないとかってエラー。 こっちもアンインストール。

sudo gem uninstall middleman-target

これMiddlemanのblogかそのblogをBootstrapのテンプレートを使う時にかインストールされるものみたいなんだけどconfig.rbを見ても初期状態ではコメントアウトしてるのでアンインストールしても問題なさそう。

これでエラーなしに初期化できた。

shigeki.takeguchi

渋谷の某ソーシャルゲームの会社でフロントエンドエンジニアとして働いてます。20世紀よりウェブ業界。気づいたらアラフィフ業界人です。
まだまだ現場で粘り強く作る側でいたいと思います。

By year

  1. 2017 (10)
  2. 2016 (23)
  3. 2015 (13)
  4. 2013 (15)
  5. 2012 (21)
  6. 2011 (34)

© 2012 shigeki.takeguchi